Please unbreak phabricator

Since the update, new revisions aren't posted immediately,
but first appear as drafts. There's also this message:
"This draft revision will be sent for review once this build passes:
Build 82647: pre-merge checks." (https://reviews.llvm.org/D84742)

As many have seen, pre-merge checks are flaky and just generally unusable,
and this case was no exception, the build failed and the phabricator
hsa rejected the revision: "Harbormaster returned this revision to the author
for changes because remote builds failed."
There is still no mention of that review in llvm-commits.

Please unbreak phabricator at once :slight_smile:
I don't recall seeing any discussion/proposal for any such behaviour.

Roman

Please assume good faith – I’m pretty sure this is simply a configuration mistake, since Mehdi just upgraded Phabricator to a new upstream revision last night.

Probably the default behavior changed in the new upstream version, and it just needs to be turned off.

Please assume good faith -- I'm pretty sure this is simply a configuration mistake, since Mehdi just upgraded Phabricator to a new upstream revision last night.
Probably the default behavior changed in the new upstream version, and it just needs to be turned off.

Yep, that's why i'm asking for the right configuration to be put in place :slight_smile:

See the “Draft Mode” changes, might be related https://secure.phabricator.com/w/changelog/2020.16/

MyDeveloperDay

This is configured in the “pre-merge checks” build plan, the “Hold Drafts” needs to be set to “Never”

I should be able to change this in the build plan if you want but I don’t want to step on anyone’s toes

MyDeveloperDay

Modulo this little config whopsie, thank you for updating Phab!

Bruno Ricci (and other people on IRC)

I’ve made the change

https://reviews.llvm.org/harbormaster/plan/5/

MyDeveloperDay changed the Hold Drafts behavior for this plan from Always to Never.

I apologize in advance if that was the wrong thing to do.

MyDeveloperDay.

Sorry, I didn’t notice this change of default last night.
Thanks for fixing this!

Sorry, I didn't notice this change of default last night.

Thank you for working on it!

Thanks for fixing this!

--
Mehdi

Roman

I think you did a sterling job getting it upgraded so if this was the only issue then I think we can still call it a win! Thank you.

Just as a heads up there have been a number of changes over the last 12-18 months in Phabricator with regard to AutoClosing might be worth keeping an eye out on and committed changes to make sure they are autoclosing the revision

MyDeveloperDay

You upgraded past the “Suggest Edits”… Brilliant, thank you so much, I use this all the time in my Phabricator instance!!!

https://secure.phabricator.com/phame/post/view/777/quick_look_suggesting_edits_with_inline_comments/